Welcome to Rainbow Portal Community Sign in | Join | Help

App-Domain could not be created. Error: 0x80131902

Mike Stone tonight came across an interesting issue, not with rainbow, but an issue nonetheless.
When he downloaded and went to run Rainbow 2.0 He came accross the following message

"Failed to execute request because the App-Domain could not be created. Error: 0x80131902"

Basically, this happens on first time 2.0 runs sometimes, not sure why, but the following seems to fix the problem. My suspicions and research lead me to believe it has to do with web servies referenced. To fix it, try the following....
  1. With a command window, get to the latest version of .net under
  2. C:\Windows\Microsoft.Net\Framework\
  3. Now run the following command: "net stop w3svc" to stop web services.
  4. Then use "aspnet_regiis.exe -ua" to uninstall all instances of ASP.NET from IIS.
  5. Follow with "aspnet_regiis.exe -i" to install ASP.NET into IIS.
  6. Now restart web services with "net start w3svc".
Published venerdì 10 marzo 2006 4.52 by Jonathan

Comments

# re: App-Domain could not be created. Error: 0x80131902

venerdì 10 marzo 2006 17.41 by ramseur
You dont have to do all that to fix it. A simple recompile fixes it for me. Sometimes I think app_domains get corrupted and you get a kick out error. I dont have to uninstall anything to get it to work...just a simple recompile.

# re: App-Domain could not be created. Error: 0x80131902

venerdì 10 marzo 2006 21.20 by Jonathan
Well, what about a user who is only using the website, so he hasn't compiled, and is not going to compile anything, perhaps does not even have visual studio or any tools to compile.
Think about a user who download the rainbow web site to use ( most users will fall into this category i think ). and he goes to use the site and catched that errror.
I afree recompile is the easiest fix... but it's nice to know there is a workaround when comiling is not an option.

# re: App-Domain could not be created. Error: 0x80131902

domenica 27 agosto 2006 8.23 by rob
Exactly my situation - not wanting to recompile - worked for me - many thanks. Note: aspnet_regiis.exe lives in subdirectory of that given above (subdirectory has name of framework version - choose the one you are running).

# re: App-Domain could not be created. Error: 0x80131902

martedì 21 novembre 2006 6.07 by barnard_rob
Jonathan,

Thank you Jonathan and Mike, the fix works.

I tried recompiling and all to no avail.  One difference between Mike Stone's configuration and mine is I still had v1.1 of ASP.NET (along with v2); had to drill farther down the path to find & execute aspnet_regiis.exe.  Running the version 2 of aspnet_regiis.exe removed everything.

The application is working well now.  Thanks.

Rob
USA, Michigan

# the rasx() context » Blog Archive » Today???s Software Development Links

# CrossRoads

venerdì 21 settembre 2007 4.58 by CrossRoads

# Quarter to Twelve » Blog Archive » App-Domain could not be created. Error: 0×80131902

# re: App-Domain could not be created. Error: 0x80131902

giovedì 14 febbraio 2008 12.05 by vainternet

give access to the ASPNET and IIS_WPG account names to the directory by right clicking on the directory, properties > security > add

# re: App-Domain could not be created. Error: 0x80131902

venerdì 23 maggio 2008 15.42 by swexpert

Hi,

Adding to those comments of domenica and Rob, I'd like to add again that aspnet_regiis.exe is not within the system path.

So one has to goto

C:\Windows\Microsoft.NET\Framework\{Framework Version} Instead of C:\Windows\Microsoft.NET\ as mention in Jonathan's steps

{{In my case it was C:\Windows\Microsoft.NET\Framework\v2.0.50727 despite the fact that I had versions 1 and 1.1 installed as well. }}

Secondly trying to replicate the error, I observed that before fixing the error using the above listed method by Jonathan, the control seemed to be going straight to .Net and not via IIS, causing the error. In other words. Just stop the w3s service and it will start behaving weird again...stop the service, open a non-existent page ../something.aspx and it will keep on showing the earlier page (from cache maybe?).

Thanks Jonathan.

Regds

Inderjeet

# re: App-Domain could not be created. Error: 0x80131902

mercoledì 9 dicembre 2009 18.58 by CD Rates

thanks, this cleared this right up

Anonymous comments are disabled